AW4 trans issue??

Okay AW4 guys…whats going on here?? I installed the AW4 that was removed from a running / driving 1999 cherokee so I know it was working at least back then it was… Installed it into my TJ and now it is slipping…

Here’s whats happening:

  • Shift into reverse and I can feel it shift into reverse and the jeep moves but will slip if I give it some gas
  • Shift into drive and it somewhat goes into gear, give it some gas and the RPM’s increase but the jeep doesn’t move very much
  • Tried this in all forward gears with the same results.

Here is what was done to it…

  • Adjusted the TV cable per the service manual
  • Pan removed and screen changed
  • Drained the converter or the old ATF by leaving it flipped upside down for a couple days to drain into a bucket (lots of fluid came out).
  • Added about 1.25 quarts of ATF4 into the converter before installing it back into the trans
  • Filled the trans with ATF4 (don’t remember but I found 8 empty bottles)
    • brought the engine up to temp and then checked the fluid level in both “N” and “P”. Its showing a little over filled in “P”…

It feels to me like it is low on fluid but the dipstick says it is full… Yes, its the original dipstick…

Did a search on other forums and some say ATF4 is right others say stay away… Anyway…not sure what to check / try next…

You should only use dex/merc III it is a Japanese trans not a chrysler trans.

The t-converter takes about 3.5 quarts to fill it.

What flex plate did you use? did it come from the cherokee you got the trans?

It sounds like you are not getting pressure from the front pump. are your trans coolant lines hooked up properly.

What did you do for a fluid cooler?

other things that could be the problem are you broke the front pump when putting the trans and block together. Or the pick up on the oil filter are not seated wright.

pulled from another board

Good afternoon and thank you for contacting Valvoline Product Support.

The AW4 automatic transmission on your 1996 Jeep Cherokee requires Mercon as the fluid, to which the ATF +4 is not compatible replacement. ATF +4 is perfectly acceptable to substitute in place of ATF +2 or +3 applications but does not cover any of the Mercon specifications. Slipping in the transmission may occur when an incorrect fluid is being used.

The Valvoline Dex/Merc ATF and ATF+4 are not compatible fluids, as they cover different specifications. There is no concern over the fluid being conventional or synthetic. We would recommend performing a transmission flush on your vehicle to remove the incompatible fluids from your torque converter. The Valvoline MaxLife Dex/Merc ATF is what we would recommend for use in the automatic transmission of your vehicle.

Thanks for the help! See my comments, questions and answers below (in red).

“You should only use dex/merc III”…UGH that was a waste of $65.00 for the ATF4… Now to figure out how to get the old stuff out… Will get some Dex/Merc III tonight.

“The t-converter takes about 3.5 quarts to fill it.” We tried to fill up the converter but it was taking to long. We managed to get 1.25 quarts in before it was installed. Definitely removed a lot more then that when it was drained…

“What flex plate did you use? did it come from the cherokee you got the trans?” I used the flex plate / flywheel and spacer plate from the XJ

“It sounds like you are not getting pressure from the front pump.” Any suggestion on how to check this?

“Are your trans coolant lines hooked up properly?” The trans lines are from the XJ as well. I had to cut them and use a barb fitting into the radiator (barb fittings came with the new radiator).

"What did you do for a fluid cooler? " I am using the trans cooler inside of the TJ radiator.

“Other things that could be the problem are you broke the front pump when putting the trans and block together.” This is possible as I didin’t have it engaged fully when we bolted the engine and trans together. Found it when we tried to rotate the engine by hand. Took it all apart and engaged it right.

“The pick up on the oil filter are not seated wright” I have heard about this happening… once the trans is drained I will drop the pan and check.

You sure u have it all wired right …aw4 is all electronic controled.mine did the same thing a year ago and it was the tps

At this point, no I am not sure… I just read that I could disconnect the TCU and it will shift manually… will try that tonight

That’s how I got my jeep home.the only thing u will not have 2nd gear 2nd is completely electronic

speaking of wiring… xjtalk.com/showthread.php?t=8407

I don’t know why your trans is slipping, but as far as cooling, use an aftermarket cooler as opposed to the radiator. I had overheating issues with my trans and my motor, because when the radiator is used to cool both, they feed off of each other. I disconnected my trans from the radiator and put a trans cooler in front of the radiator and haven’t overheated once since. Just figured I’d share what I was dealing with.

Thanks for the cooler suggestion… a soon as it is up and running a cooler will be going in…

Update:

Pulled the TCU per 90XJ’s suggestion - no change… some power in reverse and 1st but nothing in 3 and slips a lot in D. In 1st I do have what seems normal power to the trans. Can only move a few feet since I am in a garage but enough to tell if its slipping or has power.

Removed the pressure side line at the radiator and stuck it into a bucket. Fired up the engine and about 2 to 3 quarts came out by time I could tun to the front, check it and then turn off the engine… pump is working…

Now to the fluid… this fluid has ZERO miles on it and was dark already… not sure if this is a sign of a bad trans or if it was darkened by the old trans fluid left over in the converter that couldn’t be drained out???

Thinking I got screwed and have a bad transmission… Thoughts??

it might have burned up a bit, did you try the other fluid option yet?

If the tcu is not hooked up right you should only get second gear and forth but being in second it would go.
If the solenoids went bad you would have the same problem as the tcu not hooked up.
It could be electrical.

I skipped putting in a tcu when i did the aw-4 swap in the buggy and use this–> http://www.radesignsproducts.com/Rail.html

What you can do is put the dex/merc III in a bucket then run the return line into it with another bucket on the pressure side to catch the atf+4 which will flush the fluid. I would try this.

i would bypass the radiator and go right to a external cooler.

Mike,
Thanks again for the help… I purchased 3 gallons of Dextron III/Mercon for the flush and will be doing the oil change when I get home tonight.

That shifter is pretty cool… Does it allow for full automatic shifting when not is use and full manual when used or is it full manual?

I am thinking that your suggestion about it being electrical might be right… found this on another forum… sounds almost exactly like what mine is doing although it is an older AW4…

"I have a 92 XJ w/ the AW4 and about 200,000 miles. I just got this XJ a couple nights ago. Last night it would barely go forward (I rev it and it would not do anything) when going from a stop in either “D” or 3rd. In 1-2 or reverse it worked fine. On flat ground or with some momentum “D” works fine, it’s just when it starts from a stop on a hill. Fluid level and color is fine. And this is on my steep driveway after starting the vehicle, so it is not overheating. Any ideas?"

Here is the reply (best one as there were others…) Posting this here in case anyone else has this same issue…

"[i]If the TCM is bad (or the fuse is simply blown), you’ll get 4th in (D), 3rd in (3), and 1st in (1-2). This is a failsafe as you don’t want the tranny dropping into 1st gear on the freeway if the fuse pops. The first test in the FSM is to pull the fuse and verify this is what happens. From the description, the problem sounds like its on the electrical side of the house. Trying to start in 4th it will seem like it’s really slipping.

In order of probability for AW4 problems:

  • Erratic shifting is usually the TPS, but doesn’t sound like your problem
  • TCU doesn’t have power, such as blown fuse. Check for power at connector.
  • Bad solenoids. Easy to test using a meter at the TCU connector.
  • Bad speed sensor. Cause it to not upshift - not your problem.
  • Bad TCU. Fairly rare. I’m only heard of 4 confirmed bad ones"[/i]

So after the oil flush I will be checking the wiring to make sure I did it right, checking the solenoids and checking the TCU for power…

thanks again to everyone for the advice and help… missing driving my jeep… :neutral_face:

my problem was the tps but its a 90 and I had no forward gears though…

Hey glen u up and running yet

Today’s update…

Tad its running but not moving very well…

Changed over the fluid from the ATF4 to the Dextron III/Merc - no change… still no power in D or 3 but good in R and 1. I didn’t think that was the problem but its nice to have the right stuff in there now.

Treating this as an electrical problem… I did Ohm out the 3 solenoids and got 12 ohms at each. Its suppose to be around 15 but the tranny fluid was cold when I tested it…

I beeped out every connection that was made and fired the guy who made the wiring harness but since that was me I had to fix it… I found 2 lines were connected to the wrong pins with both being on the GRAY TRS connector. Pins #2 & 4. Pin 2 supplies 12v + to the TCM to indicate the shifter is in the 3 range and pin #4 provides 12v + to the TCM to tell it that the shifter is in the OD range…

Fixed the two mixed wires, plugged in the TCM and tried it with no change…

Aside from checking continuity and correct pinouts, I did check power and ground…

Checked the constant 12V + at pin 25 which was good (12V)
Checked the switched 12v + at pin 26 which was good
Checked ground at pin 24 and it too was good…

Last thing I tried was to power the solenoid manually. Following the directions I found on RAdesigns website (manual shifter folks)
Start it and put it into drive and apply 12v +
Powered solenoid 1 should go into first - I heard the “click” of the solenoid but it didn’t go into first - still no power
Powered solenoid 2 - should still feel “boggy” - Yup that’s how mine feels… did hear it click as well
Powered solenoid 3 - should stall engine - nope…nothing happened other then I heard it click…

Fluid level was at the full mark but who knows…maybe I cant read a dipstick anymore :laughing:

It has to be something stupid that I am missing or over looked…

What a nightmare. Makes me nostalgic for the days when all this electronic crap did not exist.

Eric I 100% agree… The sad part is there really is not that many wires to connect… Most are going from the TCM to the connectors and these need to be connected because the get cut out of the donor harness. Other then that you are looking at 10 - 12 wires…

dont know if this is the pic you went off.

Was your jeep auto from the start? is there a check valve on the radiator on the return side?

Did you unplug the tcu while applying juice to the solenoids?

I did see that but that was not where I got the info from. I got it http://www.radesignsproducts.com/uploads/Rail_Wiring_Customer_Copy.pdf which is the installation sheet for the rail / baja shifter.

Here is the portion i used to test mine:
“Finding which transmission wires to connect controller to:
It’s recommended that you have help with this for safety.
Using masking tape tags mark the three transmission control wires “A”, “B”, and “C”.
With the engine running and floor shift selector in Drive. Connect a 12V+ jumper to the wire that you
marked “A”.
If this is the #1 solenoid wire you should feel the transmission shift down to 1st gear and easily move forward
when the throttle is applied.
If this is the #2 solenoid wire the transmission will still feel boggy.
If this is the Torque Converter Lockup wire the engine should stall.”

My jeep was a 5-speed to start with

I don’t think there is a check valve on the radiator… the two fittings are hallow barbed fittings

The TCU was unplugged when I applied voltage to the solenoid