SERV 4WD light problem

My Serv 4wd light came on and when I put the jeep into 4H or 4L those lights would flash. Seems like it is not engaged. Only code it is producing is U0010 “Medium Speed CAN Comm Bus” which I do not think it has anything to do with the 4wd drive. I think, it is due to the Superchips reader but not sure.

I have tried to the following steps and still not fixed, and I am running out of ideas.

  1. Check the wire connect on the FAD. It was not loose, but I disconnect it and clean the wires just in case.
  2. Check and change the T-case fluid. it was about a half Qt low.
  3. replaced the transfer case switch
  4. check all the linkage on the T-case and everything is connected.

I have read so many forums and watch too many videos and cannot see to figure out what it might be. At this point not sure if I should go back to the dealership or a different shop.

I will take any suggest anyone has…



2020 JLU Unlimited Sport S - 3.6L Gas

Here’s the problem: Too many buttons, Too many computers, Too much wire! :rofl: :rofl: Jeep has lost all their KISS principals!

If you want, swing by my shop Ocean State Off Road and I can see if my Snap-On Zeus+ can see anything more. These newer jeeps have a secure gateway and I pay a subscription to able to scan these 2018+ jeeps.

We might be able to see more than you can with your flashcal

1 Like